JRapid Eclipse Plugin Installation Guide

From JRapid

Jump to: navigation, search

This is a step-by-step guide to installing the JRapid's Eclipse plugin in Eclipse 3.2+ and Eclipse 3.5+. You may read the Getting Started with JRapid Eclipse guide to get a quick idea of how to build web applications using the JRapid Eclipse plugin.

Contents

Eclipse Update Sites


Eclipse 3.5+

1. Open the Eclipse IDE. 2. Go to Help > Install new software. 3. Click on the Add button.



4. Choose any name and type http://eclipse.jrapid.com/update-3.5/ as the location.



5. Select the recently added location in the Work with field and wait for the available software to appear.



6. Select the available software and click Next. 7. Wait for the installation to finish, accept the license agreement and accept to restart Eclipse. 8. Go to Window > Show View > Other ....



9. Select both JRapid Conflicts and JRapid Manager views and click OK.



10. The views will appear at the bottom right of the IDE.


Eclipse 3.2

1. Open Eclipse IDE. 2. Go to Help > Software Updates > Find and install .... 3. When the window pops-up, choose the Search for new features to install and click Next. 4. Click the New Remote Site ... button. 5. Choose any name and complete the URL field with http://eclipse.jrapid.com/update/ if you are using Eclipse 3.2.*, 3.3.* and 3.4.*. 6. Verify that the site is checked and click Finish. 7. Next, the window will display the available features. Check JRapid Feature 1.0.x and click Next. 8. Accept the license agreement. 9. Default installation directory should work fine. 10. Don't worry about the unsigned features warning, a lot of well known companies provide unsigned features.


See also

Personal tools